How to restore a FS 613A M136

* Caution: With this modifications the ip camera lose the warranty and this is not guaranteed to work for all ip cameras. I’m not responsible of a bad use of this manual, take care with all, cables, voltage, to weld ….

Perhaps you brought a very cheap ip camera in Ebay or others online shops in Xina. The ip camera didn’t have any information but is very similar like Foscam FI8908W and the last firmware is different than you have in your new ip camera …. if you update ip camera with the last FI8908W firmware, it will restart every 3 seconds, impossible to come back or delete the firmware. To solve this problem is noy easy, but is possible.

Is important identify the model and the factory of the ip camera:

In a small sticker indicate the model (FS 613A M136), and searching in Google we can deduce that this ip camera is a clon form EasyN Technology Co. Ltd company (http://www.easynp.com). This company manage a lot of differents models of ip cameras, all of them very similar like Foscam models. The webpage there is a lot of information of the ip cameras without their respective firmware.

Finally, I found the last firmware to FS 613A M136 ip camera (is very very very long history), and there are the files:

Device Firmware Version: lr_cmos_4_11_2_15
Device Embeded Web UI Version: aw_4_3_3_39

The FI8908W (Foscam) and the FS 613A M136 (EasyN) PCBs are the same:

FI8908W:

FS 613A M136:

And for more information about some parts of PCB with their datasheets:

DM9161AEP: Davicom 10/100 Mbps Fast Ethernet Physical Layer Single Chip Transceiver (PDF)
alc203: Realtek TWO CHANNEL AC’97 2.3 AUDIO CODEC (PDF)
W90N745CDG: Winbond 32-BIT ARM7TDMI-BASED MCU (PDF)
W9812G6IH-6: Winbond 2M X 4 BANKS X 16 BITS SDRAM (PDF)
S29AL016D90BAI013: Spansion 16 Mbit 3.0 Volt-only Flash memory (PDF)

This is a bit introduction about FS 613A M136.

What we need to restore?

We need to conect the ip camera with the computer (caution: the ip camera works with 3.3V),  I use an USB to serial UART, it costs arround 9€

Now conect the pins with our FS 613A M136, but carefull, you need to cross RX with TX and TX with RX!!!

USB to Serial
—————
IP Camera
————-
3.3V

TX

RX

Gnd

==>

==>

==>

==>

3.3V

RX

RX

Gnd

Like this:

Look 4 pins: inorder 3.3V, Gnd, TX, RX (remember to cross TX and RX)

Follow the cables

Next step is upload the linux.bin and romfs_cmos_11_14_1_37.img file to the ip camera (W90N745CDG: Winbond 32-BIT ARM7TDMI-BASED MCU and W90N745 uClinux BSP User Manual).

Conect you your USB at the computer, and start the Hyperterminal with this configuration:

Conecting ussing: COM1 (select your default port)

Bits per second: 115200
Data bits: 8
Parity: None
Stop bits: 1
Flow control: None

Open the connection

Power on your ip camera (conect the power supply), Hyperterminal starts to show letters and press ESC

Now we can delete the memory of the ip camera. Write:

First => bootloader> del 6 (press enter and wait to finish)
Second => bootloader> del 7 (press enterand wait to finish)

And then we can upload the files roms.img and linux.zip (download here) and write with carefully:

bootloader> fx 7 linux.zip 0x7f020000 0×8000 -acxz (press enter)

Select: “Transfer -> Send file” or right click with the mouse and “Send”, in a File browser choose the file linuz.zip with xmodem protocol

Repeat with next file:

bootloader> fx 6 romfs.img 0x7f0d0000 0x7f0d0000 -a (press enter)

At end input: booloader> boot (press enter)

Now you can disconect the cables and conect the ip camera to lan to upload the firmware.

To upload the firmware, download and install the program IPCamSetup.exe

Finally, you can configure your ip camera :)

If the files roms.img and linux.zip don’t work fine or not update, you can try with Foscam files (in my case I could update my EasyN cam with this files), you can donwload here.

More information:

http://www.gadgetvictims.com/2009/12/bring-your-fi8908w-paperweight-back-to.html
http://www.computersolutions.cn/blog/tag/foscam
How to restore Foscam IPCam in Spanish http://www.habitacion404.com/?p=128

Thanks:

Jasper Diepstraten

And sorry for my english :P

Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported License.

www.computersolutions.cn/blog/tag/foscam/

49 Comments

  • By Bubbah, July 21, 2010 @ 2:41 pm

    Great recovery guide!

  • By magurin, July 22, 2010 @ 1:39 am

    Hello! This is my first post in this blog. A month ago I bought three cameras W90P745 model (from Chinavasion.) Everything worked perfectly until one day a camera stopped working.
    The camera turned on, but the green light on the front is not lit, either with the cable or wifi.
    I decided to buy the cable and try to come back to life using your method.

    I can connect successfully to the camera, I have completed the first two steps:

    del 7
    del 6

    But both the rise of file romfs.img linux.zip as 30% I get a message “General failure” (I select the file and put Xmodem protocol.
    That may be happening?

  • By Oskys, July 22, 2010 @ 6:01 pm

    Magurin, it is rare that one day stop working. I just send you an email with linux.zip and romfs.img of Foscam, this files work well with my camera.

  • By Bubbah, July 27, 2010 @ 2:37 pm

    One of my visitors reported that his Chinavasion camera burned 15 minutes after having been powered on (http://www.gadgetvictims.com/2008/08/foscam-fi8908w-firmware-history-page.html).
    It looks like they provide unsuitable power adaptors. Check for burned components inside the camera (unless you want to return it under guarantee), or even a distinctive smell.

  • By toadstul, July 27, 2010 @ 4:40 pm

    Hello there.
    I have the same propleme like magurin!!
    Oskys Can you please send me too the files from Foscam that you have send to magurin?
    thanks

  • By Oskys, July 29, 2010 @ 8:44 am

    sorry, at this moment I am out for a few days. When I arrive I’ll update the post. Toadstul, you can donwload the files from gadgetvictims (see the link in this p6st)

  • By john, July 30, 2010 @ 10:52 pm

    Is there any way to get the firmware from the camera as a backup before trying to update?? :)

  • By Chau Beagan, August 1, 2010 @ 1:35 am

    Nice work! great blog

  • By IP camera software, August 1, 2010 @ 5:07 pm

    Nice work! great website

  • By Security Camera, August 4, 2010 @ 10:36 am

    Nice work! great website

  • By Oskys, August 4, 2010 @ 11:48 pm

    Dave, look this guide: http://www.gadgetvictims.com/2009/12/bring-your-fi8908w-paperweight-back-to.html

    “One important point is that you need to cross INPUT with TXD, and OUTPUT with RXD.”
    http://3.bp.blogspot.com/_m16_YxsBJsw/Sypc8JPqcvI/AAAAAAAANYM/gpSlw0ENpsE/s1600-h/FI8908W-USBUART.jpg

    With this connections, my cam works fine.

  • By Oskys, August 4, 2010 @ 11:52 pm

    Bubbah, my power supply burned in 5 minutes, the seller sent me another power supply and all work fine at the moment (I’m crossing my fingers)

  • By Oskys, August 5, 2010 @ 12:03 am

    Toadstul, you can donwload the files in http://www.neknek.net/wp-content/uploads/2010/08/foscam_linux_romfs_files.zip and tell us.

  • By Oskys, August 5, 2010 @ 12:06 am

    John, I don’t know how save the firmware before to update but I think is possible, I’ll investigate how.

  • By PTZ IP Camera, August 6, 2010 @ 4:17 pm

    Hi there, anyway, thanks for the info!

  • By dave, August 7, 2010 @ 12:27 am

    hi oskis ,ok on the gadgetvictims web,but please look your photo :http://www.neknek.net/wp-content/uploads/2010/07/14072010547.jpg

    the connector on the ipcam is it reverse !
    cables ,white ,brown ,black and yellow ,must be reverse respect your photo of the ipcam pcb.

    look ? thanks -dave-

  • By dave, August 7, 2010 @ 12:39 am

    is not the same.
    only to confront that different image of connector and colors cables to tx ,rx ,gnd power , respect the inverse to the other image,and not for open flame questions. ciao – dave -

    http://3.bp.blogspot.com/_m16_YxsBJsw/Sypc8JPqcvI/AAAAAAAANYM/gpSlw0ENpsE/s1600-h/FI8908W-USBUART.jpg

    http://www.neknek.net/wp-content/uploads/2010/07/14072010547.jpg

  • By Speed Dome Camera, August 14, 2010 @ 9:49 pm

    Nice work! great website

  • By Ramon, August 16, 2010 @ 9:22 am

    I bought a IP Cam from ChinaVasion (Foscam clone) The PCB says: ES_IP607_ARM_2 Without thinking I tried to flash a FOSCAM firmware on it. It is now bricked, I have a RS232 thingy, so I can het into the bootloader and tried different linux.zip and romfs.img files, starting with the obvious one yje “Foscam Clone IP607″ recovery. When I try this one the cam accepts the files, but it keeps rebooting after that.

    I have two more good working cams, and I’m looking for a way to dump the firmware of the working cam so I can flash it to the bricked one. Does anyone have an idea how to dump the firmware of the camera?

    Thanks!

    Ramon

  • By Jimmy McJimbo, August 26, 2010 @ 1:00 am

    I tried to flash my EasyN cam with Foscam firmware (didnt realise it was a clone). It bricked the camera, constant restart. Using this guide i was able to bring my camera back from the dead. & it now has updated firmware too.

    Cheers.

  • By Oskys, September 2, 2010 @ 12:12 pm

    Bye bye Holidays. Good morning computer :’(

  • By Oskys, September 2, 2010 @ 12:48 pm

    @Dave, you are right, I’ve just changed the photo, I didn’t take another photo, only a litte photoshop.

  • By Oskys, September 2, 2010 @ 12:59 pm

    @Ramon, try to download linux.zip and romsf.img os this post, there are two different versions:

    http://www.neknek.net/wp-content/uploads/2010/08/foscam_linux_romfs_files.zip
    http://www.neknek.net/wp-content/uploads/2010/07/linux_romfs_files.zip

    Try and tell us your experience.

  • By Oskys, September 2, 2010 @ 1:00 pm

    @Jimmy McJimbo It’s great!! enjoy your cam :)

  • By wireless modem router, September 7, 2010 @ 12:05 am

    Merci!

  • By Slayck, September 16, 2010 @ 6:53 am

    I tried loading the same firmware + web ui mentioned in this webpage but I ended up with a cam that restarts every 3 seconds. And I have managed to check the web ui + firmware cmos versions and they are the same as the ones mentioned.
    Is there any other way of doing this without the USB / UART interface ? :D And in case not please tell me from where I can buy the interface.

  • By Oskys, September 16, 2010 @ 7:34 am

    @Slauck, you need the USB/UART interface, you can buy this in ebay, usually it costs between USD 10 ~ 20, in my case 9 EUR (USD 12). I had the same problem, the cam restarted every 3 seconds, but with this guide, and software, I solved the problem, the same that 2 or 3 visitors more. Tell us more information about your cam to solve the problem if you follow all the steps of this guide.

  • By Slayck, September 16, 2010 @ 6:24 pm

    Okay,I will try it after I get UART to USB piece.
    But is there any way I can extract the firmware from… because I need to work on the web ui of another similar cam. And I am really afraid to load the firmware available in this webpage.. since already the box looks the same one in this page.
    btw i have verified the web UI of provided in here and discovered that the interface is RED / Black … my original clone one is Blue and White(Very Ugly Design)……

    What I did which corrupted my cam is the following:
    1 – Loaded the Web UI FIRST
    2 – Loaded the Firmware Secondly with the IP CAM Setup tool
    MY Cam went crazy maybe because of the wrong sequence.
    Thanks All

  • By Slayck, September 17, 2010 @ 6:25 am

    Will this item on ebay works fine ?
    “USB 2.0 to TTL UART 6PIN CP2102 Module Serial Converter” Please check and tell me.

  • By Marunga, October 11, 2010 @ 10:27 pm

    Hi,

    I have “general failure” in Xmodem transfer. I think it is because I’ve done “del b31″. Can anyone please give the content of this memory block ? (execute in bootloader “d 31″)
    I have a Maygion camera, if pssoble, give the mem dump of this cam, else, give from foscam.
    thanks,
    m

  • By Marunga, October 15, 2010 @ 8:54 am

    Hello people,

    Problem solved (at least, my problem). The Xmodem file transfer works fine now. I was using a laptop with Linux (and some times a WinXP VM), I think something is wrong with the laptop serial port timers (also used a USB-> serial interface) or maybe its Linux.Now I’m using a desktop with Win7.
    Now I have to find Maygion’s original files ;-)

  • By Chakablinda, November 30, 2010 @ 4:17 pm

    Hello there,

    I have a question, how can I get this :

    Image: 7 name:linux base:0x7F020000 size:0x000BF718 exec:0×00008000 -acxz

    Image: 6 name:romfs base:0x7F0E0000 size:0×00090400 exec:0x7F0E0000 -a

    ?

    With the debug mode’s commands using HyperTerminal ?

    Regards,

  • By john, December 5, 2010 @ 12:59 am

    well i tried the upgrade firm ware,not sure if mine is a brick or not.i got the firmware loaded,but the you i is all 0′s now.when i try to install either noe it says”refused by camera”any ideals ? thinks

  • By mihai, December 13, 2010 @ 8:24 pm

    hi
    please help me
    when i press esc , doesn’t happen anything
    please give me a solution
    thanks

  • By yiannis, December 23, 2010 @ 2:52 am

    hi
    i have the camera from dealextreme with the red white box.it is a foscam fake.I have try all the firmware.Only for chinavision work but reboot continue.with another firmware i hear a voise from speaker.have you a solution for me
    Thank you

  • By JoaoPaulo, January 5, 2011 @ 4:41 pm

    Hi everybody.

    I bricked my IP camera (from DealExtreme – Foscam fake).

    I can recover the camera ONLY with this files (http://www.neknek.net/wp-content/uploads/2010/08/foscam_linux_romfs_files.zip).

    After the recover, the system FW version is 11.14.1.37 and there is no Web UI installed (IP Camera tool shows 0.0.0.0)

    So, i can upgrade the system FW version to 11.14.1.42 and 11.14.1.46, but i can’t recover the Web UI from any version.

    Any help please ???

  • By JoaoPaulo, January 6, 2011 @ 3:14 am

    When I try to update the Web UI, i got this error in terminal:

    Unhandled fault: alignment exception (13) at 0×00000001
    fault-common.c(97): start_code=0x1e2040, start_stack=0x34bf98)
    Internal error: Oops: 0
    CPU: 0
    pc : [] lr : [] Not tainted
    sp : 0061bf80 ip : 00000000 fp : 0061bfac
    r10: 003df290 r9 : 000000e1 r8 : 00012980
    r7 : 0061a000 r6 : 00000000 r5 : 0017dba4 r4 : 00000004
    r3 : 0017dbb4 r2 : 00000000 r1 : 7f200000 r0 : 0032fc28
    Flags: nZCv IRQs on FIQs on Mode SVC_32 Segment kernel
    Control: 0
    Process camera (pid: 21, stackpage=0061b000)
    Stack:
    0061bf60: 00065308 00158218 60000013 ffffff
    ff
    0061bf80: 00000004 00000004 0017dba4 00000000 0061a000 00065308 7f200000 000001
    c5
    0061bfa0: 00000000 0061bfb0 000127e0 000652b0 7f200000 0001303c 7f200000 000000
    04
    0061bfc0: 0032fc28 0032fc28 7f200000 000001c5 00000000 003df4b8 003ebcc0 000000
    00
    0061bfe0: 003df290 0032fc1c 00000004 0032fc0c 001e8cb4 001e4880 00000010 7f2000
    00
    Backtrace:
    Function entered at [] from []
    r5 = 000001C5 r4 = 7F200000
    Code: 4282c004 4a00001b (e4913004) e4a03004 e1a0ca00
    video0 closed

    HELP PLEASE !!!

  • By momo17, January 8, 2011 @ 10:23 pm

    Hello,
    i read all the messages and tutorial on the web, but still not have a solution for my problem :

    i do the unbrick the tutorial, and everithings ok, after rebooting, i have :
    system : 11.14.1.37
    WEB UI : 0.0.0.0

    after, i tried to upgrade system and web UI
    i can upgrade only the system like that :
    11.14.1.37 to 11.14.1.42 to 11.14.1.43 to 11.14.1.46
    but when i try to upgrade to 11.14.2.17, problem :
    a lot of code and at the end :
    *********************************
    Function entered at [] from []
    r5 = 00000115 r4 = 7F200000
    Code: 4282c004 4a00001b (e4913004) e4a03004 e1a0ca00
    ***********************************

    and i must do the unbrick again.

    but for the WEBUI, no one worked, i try every version at every system version, but no issue

    i use the last verion of ip camera tools :
    0.0.7.6
    0.0.0.36

    any one can help me ?

  • By Roadster, January 20, 2011 @ 9:44 pm

    I connected my bricked Pearl Robocam directly to serial port, just crossed rxd and txd, connected gnd and started hyperterminal. I only get some weird characters, about three lines long. then nothing is possible… the camera doesn´t answer any more. Do I HAVE TO use the usb converter?

  • By Lawrence, January 22, 2011 @ 2:41 am

    @Roadster.

    Its not a usb converter.

    Its a TTL to RS232 level adaptor.

    Suggest once you buy another serialport or cam to replace the one you’ve just fried, then try again.

    The reason we need to use a TTL adaptor is that the CPU outputs at somewhere between 3-5v.
    RS232 runs at -12v and +12v.
    A TTL adaptor takes the incoming voltage and converts it to the correct level needed for rs232. Typically Feeding incorrect voltage into something generally kills equipment.

    I usually use a max232 based serial version, but in the above NekNek page he’s likely using an FTDI usb version (which does 2 jobs – TTL to rs232, then putting that rs232 over usb).

  • By everst, February 7, 2011 @ 9:23 am

    Hi,
    has a big problem with clone fosca camera, I tried a few firmware or i / o error or i2c error. at this link some photos of the boards and boxes. If anyone of you have similar or knows a solution please help. http://img16.imageshack.us/g/20110207014.jpg/

  • By Pinuccio, February 16, 2011 @ 11:23 am

    HI to everybody,
    I am a newby and found very interesting this forum.I also have a bricked Foscam clone camera,
    and tried to restore romfs.img and linux.zip files taken from the archive called “IP607_Final” with the updated memory addresses .Everything has gone OK,but during the rebooting of the camera,I get this error:”ntpc.c can not resolve ip address time…ecc,ecc”.Of course IPCAMERA_tool does not find the camera via the ethernet port (or wireless).Also pressing reset button does not fix. So I ask :where is my error ? Also tried to re-flashing the 2 files.Thanks

  • By Micha, March 12, 2011 @ 8:45 pm

    Hi, i have an 7Links Robocam (Pearlcam PX-3309-675). I think, its the same as Apexis J-011-WS (the Webinterface was the same).
    A error while i installed the WebUI-Update crashed my cam. With seriell-Uart now i have installed different versions of linux and romfs, but the cam works not correct. I cant install the WebUI.
    So i think, i need the original romfs and linux for this cam.
    Please, can anybody help me?

  • By pingo, April 8, 2011 @ 9:46 pm

    Hello everyone!
    I’ve bought a similar camera over ebay.
    The sticker on it says “FS-613A-M136 b2″. I am unable to make it work with wpa or wpa2 only with an open wireless network.

    The cam’s web page reporst this:
    Device Firmware Version 4.22.2.29
    Device Embeded Web UI Version 4.5.3.44

    Is there a firmware I could flash, to get wpa2 working? Has anyone else had similar issues? Is any of you running wpa or wpa2 successfully?

    Thanks for all your answers in advance!

  • By greg, April 13, 2011 @ 1:25 pm

    same problem as pingo
    same model, same Firmware and problem getting wireless to work

    anybody can help?

  • By @ntoni, June 20, 2011 @ 2:06 am

    Thanks for the Page, I have the same camera and I damage trying to change to unsupported firmware. With this procedure I can recover my camera. Im looking for a new firmware to solve the WiFi issues.

    Device Firmware Version 4.11.2.15
    Device Embeded Web UI Version 4.3.3.39

    Any link to new working firmware will be appreciated.

  • By Matt, June 30, 2011 @ 5:02 pm

    I was having wireless connectivity issues until I set the time correctly. I first had to ‘sync with PC’ and then just use the default NTP settings.
    Hope that helps…

  • By David, August 20, 2011 @ 10:40 pm

    For the ones who may be facing the problem “general failure” with hyperterminal when uploading files to the camera.
    I solved it using the hyperterminal which came in Win XP using Win XP, do not use hyperterminal (private edition) available in internet.

Other Links to this Post

RSS feed for comments on this post. TrackBack URI

Leave a comment

 

WordPress Themes